Landis Technologies - [Microsoft Issue] Intermittent Dropped Calls When Transferring from Microsoft Teams Auto Attendant to Landis Contact Center – Incident details

All systems operational

[Microsoft Issue] Intermittent Dropped Calls When Transferring from Microsoft Teams Auto Attendant to Landis Contact Center

Resolved
Partial outage
Started about 1 month agoLasted 4 days

Affected

Landis Contact Center

Partial outage from 6:48 PM to 8:03 PM

North America Datacenter

Partial outage from 6:48 PM to 8:03 PM

Call Routing

Partial outage from 6:48 PM to 8:03 PM

EMEA Datacenter

Partial outage from 6:48 PM to 8:03 PM

Call Routing

Partial outage from 6:48 PM to 8:03 PM

Updates
  • Resolved
    Resolved

    Microsoft has completed the rollout of the fix, and we expect the issue to be resolved across all Microsoft 365 tenants. If you continue to experience any issues, please submit a ticket through https://support.landis.cloud.

  • Monitoring
    Monitoring

    Microsoft has begun rolling out a fix, and the issue is already resolved for some Microsoft 365 tenants. We are monitoring the progress.

  • Identified
    Identified

    Some Microsoft 365 tenants may experience dropped calls when transferring from a Microsoft Teams auto attendant to Landis Contact Center queue or IVR.

    Microsoft has acknowledged this issue and is actively working on a bug fix. Microsoft has provided an ETA of Friday 3/27. Microsoft ticket number 2603110040009217

    Workaround

    Configure the Microsoft Teams Auto Attendant to transfer calls to the PSTN number of the Landis Contact Center resource account instead of transferring directly to the resource account.