Landis Technologies - Portal Performance Issues – Incident details

Portal experiencing degraded performance

Portal Performance Issues

Monitoring
Degraded performance
Started 31 minutes ago

Affected

Landis Contact Center

Degraded performance from 7:20 PM to 12:00 AM

North America Datacenter

Degraded performance from 7:20 PM to 12:00 AM

Portal

Degraded performance from 7:20 PM to 12:00 AM

Updates
  • Monitoring
    UTC
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    UTC
    Investigating

    Users may randomly experience delays when loading pages or error messages in the portal. We are currently investigating this incident.