Landis Technologies - [Microsoft Issue] Intermittent Audio Prompt Playback Issues for Callers – Incident details

All systems operational

[Microsoft Issue] Intermittent Audio Prompt Playback Issues for Callers

Resolved
Partial outage 30 %
Started 26 days agoLasted about 11 hours

Affected

Landis Contact Center

Partial outage from 4:30 PM to 3:14 AM, Operational from 3:14 AM to 7:09 PM

North America Datacenter

Partial outage from 4:30 PM to 3:14 AM, Operational from 3:14 AM to 7:09 PM

Call Routing

Partial outage from 4:30 PM to 3:14 AM, Operational from 3:14 AM to 7:09 PM

EMEA Datacenter

Partial outage from 4:30 PM to 3:14 AM, Operational from 3:14 AM to 7:09 PM

Call Routing

Partial outage from 4:30 PM to 3:14 AM, Operational from 3:14 AM to 7:09 PM

Updates
  • Update
    Update

    RCA:
    A recent validation change from Microsoft in how Graph handled inputs caused certain requests to be rejected. This has caused intermittent failures and Microsoft is in the process of rolling it back. Once this was identified, we released a fix to mitigate the intermittent failures and restore normal operation. 

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    We are actively working with Microsoft on this issue and are investigating possible workarounds.

  • Investigating
    Investigating

    We are currently investigating this incident. Microsoft Graph is intermittently returning an error when attempting to play a prompt.