Landis Technologies - [Microsoft Service Issue] Teams user presence may appear incorrect in Landis contact center. – Incident details

All systems operational

[Microsoft Service Issue] Teams user presence may appear incorrect in Landis contact center.

Resolved
Partial outage
Started 5 months agoLasted about 12 hours

Affected

Landis Contact Center

Partial outage from 10:11 PM to 9:50 AM

US Datacenter

Partial outage from 10:11 PM to 9:50 AM

Call Routing

Partial outage from 10:11 PM to 9:50 AM

Portal

Partial outage from 10:11 PM to 9:50 AM

EMEA Datacenter

Partial outage from 10:11 PM to 9:50 AM

Call Routing

Partial outage from 10:11 PM to 9:50 AM

Updates
  • Resolved
    Resolved

    It appears that the Microsoft presence API is delayed or is not sending presence updates to Landis Contact Center.

    4/17/2024 1:11AM EDT We have confirmed the Microsoft Presence API is not sending valid presence data to Landis Contact Center. We have reported this to Microsoft and are working with them on a resolution.

    Microsoft has resolved the issue.

    Microsoft's RCA: A recent scheduled service update contained a change intended to optimize presence-related data flow, which was unexpectedly causing impact.

  • Identified
    Identified

    User Impact: Teams user presence may appear incorrect in Landis contact center. If Teams presence based routing is enabled on queues, call may not route to available agents.