Landis Technologies - [Microsoft Service Issue] Queue Call Routing – Incident details

All systems operational

[Microsoft Service Issue] Queue Call Routing

Resolved
Major outage
Started 3 months agoLasted 35 minutes

Affected

Landis Contact Center

Major outage from 2:15 PM to 2:44 PM, Operational from 2:44 PM to 2:50 PM

US Datacenter

Major outage from 2:15 PM to 2:44 PM, Operational from 2:44 PM to 2:50 PM

Call Routing

Major outage from 2:15 PM to 2:44 PM, Operational from 2:44 PM to 2:50 PM

Updates
  • Resolved
    Resolved

    We have confirmed Microsoft has resolved the issue.

  • Monitoring
    Monitoring

    The Azure service degradation appears to have been resolved. We are monitoring.

  • Identified
    Identified

    An Azure service is experiencing a degradation.

  • Investigating
    Investigating

    User Impact: Queue calls may not be routed to agents.

    Scope of impact: Customers may be experiencing call routing issues.

    We are currently investigating this incident.