Landis Technologies - [Microsoft Service Issue] Calls may fail to connect to Landis Queues and/or IVRs – Incident details

All systems operational

[Microsoft Service Issue] Calls may fail to connect to Landis Queues and/or IVRs

Resolved
Partial outage
Started 2 months agoLasted about 2 hours

Affected

Landis Contact Center

Partial outage from 4:53 PM to 6:38 PM

US Datacenter

Partial outage from 4:53 PM to 6:38 PM

Call Routing

Partial outage from 4:53 PM to 6:38 PM

EMEA Datacenter

Partial outage from 4:53 PM to 6:38 PM

Call Routing

Partial outage from 4:53 PM to 6:38 PM

Updates
  • Resolved
    Resolved

    Microsoft:

    We've routed the affected call requests to a healthy portion of service infrastructure and confirmed through monitoring service telemetry that impact has been remediated.

  • Identified
    Identified

    Microsoft:

    We've identified an issue in which traffic for Auto attendant and Call queue calls is being routed to an unhealthy portion of service infrastructure, resulting in impact. We're re-routing traffic to a healthy portion of service infrastructure

  • Investigating
    Investigating

    Microsoft:

    We're investigating a potential issue with users' Auto Attendant and Call Queue calls failing within Microsoft Teams.